Форум Умных Людей

Здравствуйте, гостьВход | Регистрация )

 
Ответить ·  Новая тема
 :: Верт. синхронизация в xubuntu 11.10, НЕ РЕШЕНО, НО ЗАКРЫТО
 
roolalex
сообщение 2.11.2011, 10:29
Сообщение #1


Homo Ergaster
***

Группа: Members
Сообщений: 347
Регистрация: 14.2.2009
Пользователь №: 55702
Спасибо сказали: 5




Репутация:   8  


Доброго времени суток, дамы и господа.
Ну вот и свершился выход ubuntu 11.10, а с ним и меньшего брата xubuntu.
Поставив сие чудо я был безмерно рад его простоте и строгости линий. Но радость моя была не долгой ибо настроить вертикальную синхронизацию при воспроизведении видео не получается никак. В ubuntu это решалось просто - ставим галочку vsync в настройках compiz и в настройках nvidia и вот оно счастье. Но в хubuntu нет compiza. Есть вариант поставить его , но тогда придется ставить кучу пакетов от gnome и лишиться декоратора окон xubuntu, чего бы очень не хотелось. Поиск по ubuntu.forum.ru и в google ничего не дали - одни вопросы без ответов или предложения поставить compiz.
Может кто знает способы решения этой проблемы? Xubuntu 11.10, Nvidia 9800GT, драйвер nvidia 280.05.09. Xorg`a нет.
Прошу без холливаров, только по делу. "Зачем мне это надо" я знаю и сам.
Заранее спасибо.

Сообщение отредактировал roolalex - 8.11.2011, 10:43

sNakE
сообщение 2.11.2011, 14:57
Сообщение #2


Homo Sapiens
****

Группа: Members
Сообщений: 1069
Регистрация: 17.8.2004
Из: Великий Новгород
Пользователь №: 1809
Спасибо сказали: 0




Репутация:   11  


чо? xorg в убунте уже отменили? blink.gif не верю
по старинке, с xorg, делается через gtf и вписываешь modeline в xorg.conf

нагуглил, что в убунте нет xorg.conf - говорят создать

gass
сообщение 2.11.2011, 15:43
Сообщение #3


Homo Immortalis
******

Группа: Members
Сообщений: 9396
Регистрация: 16.10.2004
Пользователь №: 2533
Спасибо сказали: 31




Репутация:   15  


Цитата(sNakE @ 2.11.2011, 15:57) *
по старинке, с xorg, делается через gtf и вписываешь modeline в xorg.conf


Цитата(Wikipedia)
Ubuntu ориентирована на удобство и простоту использования.


smile.gif

roolalex
сообщение 2.11.2011, 16:15
Сообщение #4


Homo Ergaster
***

Группа: Members
Сообщений: 347
Регистрация: 14.2.2009
Пользователь №: 55702
Спасибо сказали: 5




Репутация:   8  


Создал xorg.conf утилитой nvidia.
А теперь подробнее что и куда вставить?
Кстати vsync в настройках nvidia включена.

CODE
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer B193W"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


sNakE
сообщение 3.11.2011, 8:38
Сообщение #5


Homo Sapiens
****

Группа: Members
Сообщений: 1069
Регистрация: 17.8.2004
Из: Великий Новгород
Пользователь №: 1809
Спасибо сказали: 0




Репутация:   11  


Не нагуглил еще? Тогда вот, например http://wiki.debian.org/ru/Modelline

roolalex
сообщение 3.11.2011, 20:49
Сообщение #6


Homo Ergaster
***

Группа: Members
Сообщений: 347
Регистрация: 14.2.2009
Пользователь №: 55702
Спасибо сказали: 5




Репутация:   8  


gtf запустил, modeline получил, в xorg.conf вписал, но эффект по-прежнему "ноль". Хьюстон, у нас проблемы...

roolalex
сообщение 8.11.2011, 10:43
Сообщение #7


Homo Ergaster
***

Группа: Members
Сообщений: 347
Регистрация: 14.2.2009
Пользователь №: 55702
Спасибо сказали: 5




Репутация:   8  


Видимо, сия проблема неразрешима подручными средствами.
Пришлось сделать так:
1. В Synaptic`е ставим compiz, плюс compiz-config-manager для удобства настроек.
2. Ставим Emerald и ищем на gnome-look.org подходящую темку. Мне понравилась elementary - так больше походит на xubuntu.
3. В настройках compiz-config-manager в секции "Эффекты" снимаем все галки, кроме "Оформления окна". Так и загрузка меньше и кино не поддтомаживает.
4. В той же секции жмякае на оформление окна и в строке "Команда" меняем содержимое на "emerald --replace" (без кавычек, разумеется)
5. Добавляем в автозагрузку compiz --replace.

Всем спасибо.

Сообщение отредактировал roolalex - 8.11.2011, 10:56

usaformat
сообщение 8.11.2011, 11:04
Сообщение #8


Homo Sapiens
****

Группа: Members
Сообщений: 1070
Регистрация: 13.1.2010
Из: Великий Новгород
Пользователь №: 70339
Спасибо сказали: 54




Репутация:   5  


Цитата
В ubuntu это решалось просто - ставим галочку vsync в настройках compiz и в настройках nvidia и вот оно счастье.

Какое там счастье? Разрывы картинки становятся значительно меньше (некоторые могут их даже не замечать), но полностью это (+ 100 других способов) проблему не решает.
Помогает только отказ от compiz-а
Ubuntu 10.04 без эффектов, ubuntu 11.10 с uniti 2d (требуется удалить compiz) , lubuntu 11.10 - всё работает изкоропки.
xubuntu не пробовал, но в simply linux с xfce тоже всё нормально.

Сообщение отредактировал usaformat - 8.11.2011, 11:09

 

Быстрый ответ · · Ответить · Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0


 :: Быстрый ответ
Полужирный
Курсив
Подчеркнутый
Вставить изображение
Смайлики
Цитата
Код
 Аватар:
 
 Отправлять уведомления об ответах на e-mail |  Включить смайлики |  Добавить подпись
   
 

RSS Текстовая версия Сейчас: 6.4.2020, 0:03
размещение рекламы; info@onfim.com; тел. +7 (8162) 90-00-35
Рейтинг@Mail.ru